Dictation error messages reported.
Incident Report for nVoq Public
Postmortem

On January 26 and 27, we experienced delays in the post-processing of dictations. Post-processing includes persisting audio in cloud storage (Amazon S3), logging the dictation transaction information, and decrementing the concurrent dictation count for the user performing the dictation.

As a result, some users received error messages indicating that they had reached their concurrent dictation limit even though they had finished the prior dictations and received the transcribed text.

In version 14.0, we will free-up the concurrent dictation count immediately after dictations complete, allowing the user to start the next dictation immediately. Post-processing will then proceed asynchronously without any direct link to dictation processing.

Posted 5 months ago. Jan 28, 2019 - 16:31 MST

Resolved
At this time we are closing this incident. Users who reported error messages have confirmed that dictations are now working. We will continue to monitor the health of the system.
Posted 5 months ago. Jan 27, 2019 - 15:42 MST
Update
We have received confirmation from a few users that dictation services are currently functional but we will continue to monitor the situation.
Posted 5 months ago. Jan 27, 2019 - 15:11 MST
Monitoring
We have restarted internal services and are closely monitoring the accounts that previously reported errors.
Posted 5 months ago. Jan 27, 2019 - 14:04 MST
Investigating
Error messages are being reported for some users when trying to perform dictations. We are currently investigating the issue.
Posted 5 months ago. Jan 27, 2019 - 11:27 MST
This incident affected: SayIt at healthcare.nvoq.com (Healthcare: HTTPS Dictations, Healthcare: Websocket Dictations).