Dictations and Shortcuts not showing up on Review & Correct page.
Incident Report for nVoq Public
Postmortem

To display entries on the SayIt Administrator Review & Correct page, metadata from completed dictations and shortcuts is populated from a read-replica of the primary database in order to help reduce load on the primary database server.

On Friday, June 28, 2019 at 1:15AM MDT, an error caused the read-replica to stop replicating the dictation and shortcut metadata from the primary database server. Consequently, the Review & Correct page stopped populating new entries for completed dictations and shortcuts.

At 6:45AM MDT, replication between the primary and the read-replica was re-established, and the missing Review & Correct entries began populating on the page.

This incident did not impact real-time dictation or shortcut activity.

Posted Jun 28, 2019 - 10:12 MDT

Resolved
From 1:15AM MDT until 6:45AM MDT on 6/28/2019 completed dictations and shortcuts were not showing up on the Review & Correct page. All dictations and shortcuts performed during that time frame are now populated on the Review & Correct page and at no time was dictation or shortcut performance impacted.
Posted Jun 28, 2019 - 06:45 MDT