Canada connection issues due to SSL certificate
Incident Report for nVoq Public
Postmortem

SayIt network traffic is protected by SSL certificates, installed on the load balancers that distribute incoming SayIt traffic from the SayIt clients to the back-end SayIt servers.

Due to a configuration error, an incorrect SSL certificate was presented by the load balancers on https://canada.nvoq.com to SayIt clients between the hours of 6:00AM MDT and 8:30AM MDT on July 24, 2019.

This would have resulted in SayIt clients receiving a message that their connection to the server was no longer trusted.

At nVoq, we understand that SayIt system availability and security are critical aspects of your daily workflow and would like to apologize for this service interruption. We have implemented new checks of our load balancer configurations to prevent this type of incident from reoccurring.

Posted Jul 27, 2019 - 00:10 MDT

Resolved
This issue has been rectified. The entire Canada environment (SayIt and SayIt Admin) is completely operational. We have not received any additional inquiries for this issue. If you experience any other issues please reach out to nVoq Support at support@nvoq.com.
Posted Jul 24, 2019 - 12:36 MDT
Monitoring
Users were receiving an error message "Your connection is not private" when trying to access the Canada environment. This issue was first seen at 6 AM MT and seems to be resolved at this time. If you are still experiencing any issues please contact nVoq Support and support@nvoq.com.
Posted Jul 24, 2019 - 08:56 MDT
This incident affected: SayIt at canada.nvoq.com (Canada: SayIt Administration Portal).